INFO: Supported Operating Systems and Prerequisite Versions

Expand / Collapse
 

INFO: Supported Operating Systems and Prerequisite Versions


This article applies to:

  • Trustwave SEG (MailMarshal SMTP) 8.2
    • SEG Web Components (SQM and Web Console)
  • WebMarshal 7.4
  • Trustwave Secure Email Server 5.8
  • Marshal Reporting Console 2.6 (for SEG, ECM, and WebMarshal reports)

(For ECM/MailMarshal Exchange, see Q14131. For Service Provider Edition [SPE], see Q11588.)

Question:

  • What are the supported operating systems for Trustwave SEG, MailMarshal and WebMarshal?
  • What version of SQL Server can be used with MailMarshal and WebMarshal?
  • What versions of IIS and ASP.NET are supported by MailMarshal Web components?
  • What versions of SQL, IIS and ASP.NET are supported by Marshal Reporting Console?
  • What versions of ASP.NET are supported by WebMarshal?
  • What versions of Internet Explorer are supported for MailMarshal Web components?
  • What versions of ISA Server can be used with WebMarshal as a plugin?

Information:

This article shows supported versions of operating systems and supporting software.  

 Notes:

  • The information reflects the latest versions of the named products. For details of previous versions, see the documentation for each version.
  • The information reflects server requirements. For details of requirements for all user interfaces, see the documentation for each product version.
  • SEG 8.X and WebMarshal 7.X are native 64 bit applications.
  • SEG Web Components and all other applications are 32 bit applications that can be deployed on 64 bit systems.
  • VMWare deployments of the supported operating systems are also supported. See Trustwave Knowledgebase article Q11828.

Key:

Symbol Meaning

RTM

Release to Manufacturing, no service pack.

SPn
KBnnn

Minimum required, tested and supported service pack or Microsoft Update.

Qxxxxxx

Tested, Supported. See the KB article listed for known issues and workarounds.

Not currently supported, obsolete, or known issues.

Not specifically tested. Not yet supported. Trustwave plans to test and provide support in a later product release. For details of the policy on new OS and SP versions, see Q13687.

(blank)

Not applicable to this product.

Operating Systems and Prerequisites

The table below lists minimum compatible operating system versions and service packs. The products have been tested with the minimum compatible service pack (and in some cases with later service packs).

Note on Service Packs and Operating System updates: If product functionality is affected by Service Packs or Microsoft updates, Trustwave will work with customers to restore functionality. If a full resolution requires product development, it may not be available immediately.

Historically, core functionality of the products listed has rarely, if ever, been affected by such updates. However, Trustwave cannot guarantee future performance.

Server Operating Systems


Trustwave SEG
8.2

Trustwave
SEG Web
Components 8.2

Marshal Reporting Console
2.6

Trustwave SES 5.8

WebMarshal
7.4 

Windows Server 2019

RTM
(With Any SEG 8.X)

       RTM
(With Any WM 7.X)

Windows Server 2016

RTM

RTM

RTM


RTM

Windows Server 2012 R2
See also SQL Server service pack requirements

KB2919355

KB2919355

KB2919355

RTM

KB2919355

Windows Server 2012
See also SQL Server service pack requirements

RTM

RTM

RTM

RTM

RTM

Windows Server 2008 R2

Microsoft support terminates
in January 2020
.

 

SP1

SP1

RTM

(See note below)

RTM

SP1

Windows Server 2008 


(7.5 is the last version
to support Windows 2008)

Windows Server Core edition
(any release)

Windows 2003 R2 and earlier

Microsoft Small Business Server 2011

SP1
(Same server installation)

SP1

 

 

Microsoft Small Business Server 2008 and earlier


(Same server installation)

 

Workstation Operating Systems
(for server installation)


Trustwave SEG
8.2

Trustwave
SEG Web
Components 8.2

Marshal Reporting Console
2.6

Trustwave SES 5.8

 

WebMarshal
7.4

Windows 10
(32 and 64 bit)

See also SQL Server service pack requirements

RTM
(64 bit required.
Permitted but
not recommended
)

RTM
(permitted but
not recommended
)

RTM

Windows 8.1
(32 and 64 bit)

See also SQL Server service pack requirements

RTM
(64 bit required.
Permitted
but
not recommended)

RTM
(permitted but
not recommended)

RTM

Windows 8
(32 and 64 bit)
See also SQL Server service pack requirements

RTM
(64 bit required.
Permitted
but
not recommended)

RTM
(permitted but
not recommended)

Windows 7
(32 and 64 bit)

SP1
(64 bit required.
Permitted
but
not recommended)

RTM

RTM

(See note below) 

SP1

Windows Vista
Windows XP

NOTE: The MRC installer bundled with SQL Express 2008 R2 with Advanced Services will not perform a new installation of the SQL software on Windows XP. If you upgrade from an earlier version of MRC, you can continue to use Windows XP with SP3. Trustwave strongly recommends using a current Windows Server operating system to host the MRC installation.

Prerequisites


Trustwave SEG
8.2

Trustwave
SEG Web
Components 8.2

Marshal Reporting Console
2.6

Trustwave SES 5.8 

WebMarshal
7.4

Internet Explorer
(for Configurator and Consoles)

10 or above

IE 10 or above in Compatibility Mode required for Admin Console.

SQM works with current versions of IE, Mozilla Firefox, Google Chrome and Safari.

10 or above

MRC works with Edge, and with Firefox and Chrome current versions

9 or above

9 or above

IIS

 

As found on supported OS

As found on supported OS

 

 

.NET Framework

 3.5 SP1

3.5 SP1 and 4.0

3.5 SP1
(Note that SQL 2016 requires .NET 4.6)

 

4.6.2

SQL Server Versions


Trustwave SEG
8.2

Marshal Reporting Console
2.6

Trustwave SES 5.8 

WebMarshal
7.4

SQL 2008 and earlier


(7.5.X is the last version that supports
SQL 2008 or SQL Express 2008)

SQL 2008 R2
SQL Express 2008 R2

Microsoft support ended
on 9 July 2019
.

SP2

SP2

SP3

SQL 2012
SQL Express 2012

RTM

SP4

 

RTM

SP3

SQL 2014
SQL Express 2014

RTM

SP2

 

RTM

 

SP1

SQL 2016
SQL Express 2016

RTM

 SP2

 

RTM

 

Azure SQL Server

Supported where
SEG is deployed on Azure

 

 

 

ISA Server Versions (WebMarshal)

WebMarshal 6.10 and above does not support plugin installation to ISA Server/Forefront TMG.

WebMarshal can be installed chained to any proxy server, including any version of ISA Server.

The last version of WebMarshal that supports ISA server plugin is 6.9.  WebMarshal 6.9 ISA Server plugin is compatible with the following versions and minimum service packs of ISA Server:

  • ISA 2004: SP2
  • ISA 2006: RTM
  • Forefront TMG: RTM

WebMarshal 6.9 ISA Server plugin is not compatible with ISA 2000.

Notes on MRC Installation

  • MRC 2.6 can be installed on Windows 2008 R2. However, the included SQL Express 2016 requires a minimum of Windows Server 2012. For a new installation of MRC 2.6 on Windows 2008 R2, pre-install SQL Express 2014 Advanced Edition or earlier.
  • MRC 2.6 works with current SQL Server versions and current Operating System versions as noted above. The limitations on MRC 2.5 have been addressed in 2.6.

To contact Trustwave about this article or to request support:


Rate this Article:
     

Related Articles



Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.

Details
Article ID: 11358
Last Modified: 11/18/2019
Type: INFO
Rated 2 stars based on 21 votes.
Article has been viewed 60,699 times.
Options