INFO: Prerequisites and tips for WebMarshal Remote Console

Expand / Collapse


This article applies to:

  • WebMarshal 6.8 and above
  • Remote Console functionality

Question:

  • What are the prerequisites for WebMarshal Remote Console?
  • What are common problems using the Remote Console?
  • What authentication methods are supported by Remote Console?
  • Why does the Remote Console link not appear on the WebMarshal Home page?

Information:

The WebMarshal Remote Console is implemented as a Microsoft ClickOnce application.

  • Note: Most administrators who require access to WebMarshal administration from their workstation should install the main WebMarshal Console application. Remote Console is provided for administrators who may want to connect without a software installation (for instance, from a user workstation)

This article details the prerequisites and other tips for use of the WebMarshal Remote Console. Prerequisites generally follow the prerequisites for the WebMarshal Console standard installation.

For some common error messages see the Common Problems section below.

  • Note: Issues using the Remote Console with UAC are resolved at WebMarshal 7.4.5

Prerequisites:

WebMarshal Remote Console requires the following items on the client workstation:

  • For version 7.X:
    • .NET Framework 4.6.2
    • Microsoft Visual C++ 2015 redistributable
  • For versions 6.10 through 6.12, .NET Framework 4.0
  • For 6.8 and 6.9, .NET 3.5 SP1
  • A web browser that supports the Microsoft ClickOnce functionality
    • Internet Explorer 7 or later
    • Edge Chromium, with ClickOnce support enabled (see edge://flags)
    • Mozilla Firefox current versions may be usable with the ClickOnce extension from Breez (this extension is not supported or warranted functional by Trustwave)
    • Google Chrome may be usable with the ClickOnce extension from Menarva (this extension is not supported or warranted functional by Trustwave)
  • Browser configured to use WebMarshal as proxy.
  • For any browser:
    • You must have Internet Explorer proxy settings configured to use WebMarshal. The ClickOnce functionality uses IE proxy settings.
    • If using a browser other than IE, add http://webmarshal.home to the Trusted Sites zone.

Authentication:

  • To allow use of Remote Console you must grant access in two places:
    1. Enable users to run the Remote Console, in WebMarshal Global Settings > Remote Console
    2. Grant users access to Console features, using the WebMarshal Security Tool. The settings you make here affect access from both the Remote Console and the installed Console. By default, members of the Administrators group on the WebMarshal Array Manager server have full access.

Remote Console link:

Users access the Remote Console using a link on the WebMarshal Home page.

This link is generated as part of the {Options} tag found in the default template for the WebMarshal Home page. If you customized your WebMarshal Home page and removed this tag, the Remote Console link will not display.

To display the link, ensure the {Options} tag is included in the body of the WebMarshal Home page. 

Common Problems:

Error message: "Cannot Start Application."
Cause 1: Using an unsupported browser (such as Google Chrome with no plugin).
Cause 2: Using a browser other than Internet Explorer, but the Internet Explorer proxy setting is not configured to use the WebMarshal server. Both browsers' settings must be configured to use the WebMarshal Server.
Error message: "Failed to load snapin module" or "Could not load file or assembly"
Cause: .NET Framework is not installed or not up to date. 
Error message: "Cannot download the application" "Manifest.exe not found"
Detailed error: Could not find file 'C:\Users\Administrator\Downloads\MarshalConsole.exe.manifest'
Cause: using Edge Chromium without enabling ClickOnce Support, or Google Chrome without third party extension.
Error message: "Deployment and application do not have matching security zones."
Cause: using a browser other than Internet Explorer, and http://webmarshal.home is not added to IE Trusted Sites zone.
Error message: "The Execution level requested by this application is not supported."
Cause: UAC is enabled. This issue affects 7.X versions below 7.4.5. To resolve the error, upgrade to 7.4.5 or above.

To contact Trustwave about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.