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ERRMSG: Initialization error: 1740 - The endpoint is a duplicate

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This article applies to:

  • Trustwave MailMarshal (SEG)
  • Trustwave ECM/MailMarshal Exchange

Symptoms:

  • Restarting MailMarshal services
  • Starting MailMarshal services in debug mode
  • Error message: Initialization error. Unable to initialize RPC server
    Make sure you are not already running MailMarshal Engine
    1740 - The endpoint is a duplicate
  • This error can be raised by any MailMarshal service. The service is named in the error text

Causes:

  • The service you are starting or re-starting is already running.
  • MailMarshal services under load can take considerable time to stop, because they must complete existing transactions first.

Resolution:

  • Ensure that the relevant service is stopped and then try again.
  • The preferred action is to wait for the service to stop. You can end the service forcibly, but Trustwave does not recommend doing so as data might be lost.


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