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FAQ: Windows Firewall Class not registered

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This article applies to:

  • Trustwave SEG
  • Installation or upgrade

Symptoms:

  • Warning message displays: Windows Firewall: Class not registered

Causes:

  • The Windows Firewall service is not running
  • SEG attempts to update firewall settings to allow the SEG services/executables to accept inbound connections through the firewall, but cannot do so

Resolution:

  • If you have intentionally stopped or disabled Windows Firewall, you can safely ignore this message.
  • If you have not intentionally stopped Windows Firewall, you should investigate further why the service is unavailable.

Notes:

If you use another firewall, ensure that the appropriate services or ports are allowed. For a list of required ports see article Q10905.

If you later want to re-enable Windows Firewall, you should update firewall rules to allow the ports or SEG executables listed below, to accept inbound connections in the active profile of the server. You can add these entries manually. You can also add these entries by running the installer in Repair mode (doing this could have other consequences).

Note that in an array installation not all of these executables exist on all servers in the array.

  • MMArrayManager.exe
  • MMController.exe
  • MMUpdater.exe
  • MMReceiver.exe
  • MMEngine.exe
  • MMSender.exe
  • MMPOP3.exe (only required if you have configured SEG POP3)

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